Symbian - App

Hallo Leute,

ja es ist ein Wunder, aber ich benutze immernoch ein Symbian Handy (Nokia E7). Ich hab schon langer vor mir eine kleine App zu schreiben (fürs Karteilose lernen für Unterwegs). Das ist an sich nicht schwer aber ich komm gar nicht bis zum eigenen Programm, denn es ist erstaunlich schwer die passende Umgebung ran zu bekommen.

Ich entwickle überwiegend auf Eclipse (bin grad auf Luna “umgestiegen”) und werde in Zukunft (arbeitsbedingt) auch auf Intellij entwickeln.
Ich hab es nach Wochen immernoch nicht hinbekommen schlichtweg JavaME auf Eclipse zu bekommen. Tausende von Dead-Links, tote Plug-Ins die Eclipse nicht erkennt. Das ging soweit das ich feststellen musste, dass es eine ganz eigene Eclipse-Version gibt nur für Mobile-Programming (Eclipse Pulsar oder so ähnlich).
Wenn ich mal was zum Laufen bekommen habe ging es natürlich nicht für Symbian SDK.

Ich bin ziemlich verzweifelt weil ich mir nicht vorstellen konnte, dass es so schwer sein soll eine kleine App zu schreiben. Für Android ist das ja im Handumdrehen getätigt.

Ich hoffe ihr könnt mir helfen. Wie entwickel ich eine App für Symbian? Die ist nur für mich und soll auch nicht veröffentlicht werden (der Store ist soweit ich weiß ja geschlossen für neue Apps).
Ich würd gern auf Eclipse (oder halt Intellij) bleiben aber wenns gar nicht anders geht, hör ich mir auch das mal an.

Liebe Grüße und vielen Dank
Highchiller

*** Edit ***

Ich habs jetzt geschafft Android (ADT) auf Eclipse zu ziehen und zu integrieren (scheint als wenn Eclipse Lunar damit deutlich weniger Probleme hat) und sogar das Symbian SDK konnt ich integrieren.

Jetzt fehlt mir doch nur noch JavaME für Eclipse oder nicht? Und nu gehts richtig los… wo bekomm ich das her?
how_to_integrate_java_me.
Schöne Idee, geht nur leider nicht. Eclipse sagt nach dem Versuch die Spezifikationen zu laden:

Cannot satisfy dependency:
From: Mobile Tools for Java SDK 1.1.2.201101310801 (org.eclipse.mtj.sdk.feature.group 1.1.2.201101310801)
To: org.eclipse.mtj.feature.group [1.1.2.201101310801]
Cannot satisfy dependency:
From: Mobile Tools for Java 1.1.2.201101310801 (org.eclipse.mtj.feature.group 1.1.2.201101310801)
To: org.eclipse.mtj.core [1.2.1.201101310801]

Nagut denk ich mir, dann halt per Hand:
Oracle JavaME-SDK eclipse plugin (starke 10KB/s downloadrate)
Eclipse hat dann zwar erkannt, dass sich um plugins handelt, konnte Java ME SDK jedoch wieder nicht installieren.

Vllt bin ich auch zu blöde.
Aber wie bekomme ichs hin, dass ich ein einfaches MIDlet in Eclipse erstelle?

Das liegt daran, dass JavaME offiziel tot und begraben ist.

Könntest höchstens mit steinalten Eclipse Versionen Glück haben, wie Eclipse 3.3 oder 3.4, dafür war nämlch das Plugin.

Android dagegen ist sehr lebendig…

Hmm, allerdings wurde grad JavaME 8 mit veröffentlicht oder nicht?

Naja ist ja auch egal, wie kann ich denn dann eine App für Symbian entwickeln und dafür Java benutzen?

Ich habe für Symbian auch schon JavaME Apps entwickelt, allerdings nur als Übungsaufgabe währned des Studiums. Lief auf Nokia S60 3rd super. Entwickelt habe ich mit Eclipse, welche Version genau…keine Ahnung mehr. Aber es geht.