Tomcat Versionsproblem?

Hallo zusammen,

Problem ist folgendes:

…ich habe also TomEE Plume v8.0.1 heruntergeladen, anschliessend ein neues Eclipse (4.9.0) J2EE „Dynamic Web Projekt“ kreiert und dann versucht den TomEE ins Eclipse zu integrieren.

Somit gilt wohl:

TomEE-Plume v8.0.1 == Tomcat 9.0.30 ??

Habe schon sooo lange nix mehr damit gemacht, aber mit sowas hätte ich jetzt keinesfalls gerechnet…

Wieder mal alles andere als intuitiv, auch nicht besonders logisch. Aber vielleicht weiss jemand von euch weiteres zum Thema?

Zwar ein wenig off-topic, würde mich aber trotzdem auch interessieren: Wikipedia schreibt was von „TomEE Plus“ (https://en.wikipedia.org/wiki/Apache_TomEE ), während davon hier nix zu entnehmen ist: http://tomee.apache.org/comparison.html

Von Plume erwähnt Wikipedia allerdings wiederum nix…(?)

Aha, „TomEE Plus“ vs. „TomEE+“ (-> Wikipedia)

Plume kann offenbar, gemäss der Vergleichsmatrix, am meisten, deshalb werde ich mal den einsetzen…

:wink:

Nachtrag: Also eine Suche mit „tomcat 9“ sowie „plume 8“ gibt schon mal kaum (relevante) Treffer:
https://www.google.com/search?rlz=1C1AZAA_deCH811CH811&ei=IhdNXtb1Aq-bk74Pg_qykAw&q=„tomcat+9“+„plume+8“&oq=„tomcat+9“+„plume+8“&gs_l=psy-ab.3...5060.5152..5248...0.0..0.202.391.0j1j1…0…1…gws-wiz.rdJ5dTsxDnk&ved=0ahUKEwjWju3xvN3nAhWvzcQBHQO9DMIQ4dUDCAs&uact=5

Aha, TomEE ist keine spez. Tomcat-Version, sondern ein davon unabhängiges Produkt welches Tomcat als Servlet-Container nutzt. Sieht jedenfalls ganz danach aus…

weniger ist oft mehr, zB. embedded Jetty, kommt mit Spring Boot (oder embedded Tomcat), startet viel schneller und Spring liefert dann den Rest an „EE“ Zeugs.

Ich kenne Tomcat mit OpenEJB von früher her - von daher passt da TomEE+ perfekt - die „Plum“-Version muss es dann doch wieder nicht sein. :wink:

Trotzdem danke!