MariaDB root Kennwort setzen geht nicht, frische Debian Stretch 9.6.0-Installation!


#1

Hallo zusammen

Hier das Protokoll:

Last login: Mon Dec 10 16:33:28 2018 from 192.168.178.184
root@xtest:~#
root@xtest:~#
root@xtest:~# service mysql stop
root@xtest:~# mysqld_safe --skip-grant-tables &
[1] 837
root@xtest:~# 181210 16:35:39 mysqld_safe Logging to syslog.
181210 16:35:39 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql

root@xtest:~# mysql -u root
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 2
Server version: 10.1.37-MariaDB-0+deb9u1 Debian 9.6

Copyright © 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
MariaDB [mysql]> update user set password=PASSWORD(“123456”) where User=‘root’;
Query OK, 0 rows affected (0.00 sec)
Rows matched: 1 Changed: 0 Warnings: 0

MariaDB [mysql]> flush privileges;
Query OK, 0 rows affected (0.00 sec)

MariaDB [mysql]> exit;
Bye
root@xtest:~# service mysql stop
root@xtest:~# service mysql start
Job for mariadb.service failed because a timeout was exceeded.
See “systemctl status mariadb.service” and “journalctl -xe” for details.
root@xtest:~#
root@xtest:~#


#2

Der Artikel im Byte-Welt-Wiki könnte helfen:
https://wiki.byte-welt.net/wiki/Kein_Zugang_für_phpMyAdmin_für_Benutzer_root


#3

Danke für Deinen Beitrag!!

Habe alles “wie gewohnt” gemacht, also für MySQL… bei MariaDB sind ein paar Sachen halt doch ein wenig anders. Des Weiteren hatte ich den root-Account auf “localhost”-Ebene anders definiert also für ‘%’…

Gruss,
Jan


#4

Gelöst? Dann bitte abhaken. :wink::+1: