Missing opencl.dll


#1

I have tried installing ATI Stream SDK v2.1 multiple times on my machine once with windows 7 and second with Vista. But at no point it creates an opencl.dll
Could anyone help me with what I am missing?

one more thing my graphics adaptor is

ATI mobility radeon HD 4530

Graphics hardware profile.
Maximum Bus Setting PCI Express 2.0 x16

BIOS Version 011.022.001.005
BIOS Part Number BR32687.001
BIOS Date 2009/04/09

Memory Size 512 MB
Memory Type DDR3

Core Clock in MHz 500 MHz
Memory Clock in MHz 667 MHz
Total Memory Bandwidth in GByte/s 9 GByte/s


#2

Hello

After the installation, you should have a directory
\Program Files\ATI Stream\bin\x86
which should contain the OpenCL DLL (and as far as I remember, it is also copied into the Windows System directory).

At the moment I only have installed the Stream SDK 2.0 (and not 2.1), since I’m using an NVIDIA card. If you still have problems with the SDK 2.1, I’ll try to update to 2.1 and see if anything has changed there. (In the worst case, the native JOCL DLL does not work with the latest version of ATI’s library, but it should work, in general…)

bye
Marco


#3

Hello Marco
This part is solved. I successfully installed and opencl.dll now existed in its appropriate path. However while installation i did observe a message which I have posted as an attachment. I would like to know what impact will it have on my computation and why did it show this warning in the first place. here is my system profile
OS- windows 7
ATI Stream- v2.1 (I thought of trying 2.0 i couldnt find an installer)
Graphics Chipset ATI Mobility Radeon HD 4500 Series
Driver:- ATI Catalyst™ Mobility 10.5 (the ati webiste said tested driver as 10.4 but again i couldnt find that driver and i am not sure if this can be an issue)

After installation I ran two demos from your site viz
1.JOCLSample.java
2.JOCLSimpleImage.java

Observations.

  1. after running program 1. the computation successfully carried but a message was left (after showing the relevant output)
    *** CAL version mismatch:
    This OpenCL build requires version 1.4.467, version 1.4.344 installed.
    Aborting.

  2. the second program couldnt create a GPU context at all. I saw the program and i didnt see ne difference from the 1st where the context is created
    also it threw the same message
    *** CAL version mismatch:
    This OpenCL build requires version 1.4.467, version 1.4.344 installed.
    Aborting.


#4

I observe now that even in program 1 the GPU context is not created.
I assume its because of the installation issue.kindly guide


#5

Hello

A websearch on the error message indicates that this “CAL version” error ist quite common. The first threads about this say that this is usually a driver issue, but with 10.5 you already have the latest driver (BTW: On this downloads page version 10.4 still seems to be available, but I think it should not be necessary do actually downgrade a driver…). On the stream SDK website, there is a small footnote behind the “4500 Series²” that only says “²Beta support” - whatever that means.

Maybe chances for helpful answers to this issue are higher in the AMD forums, since at the moment I can hardly do anything more than searching the web for any hints, and unfortunately I did not find much information about your specific card and which with which drivers are necessary to use this GPU with OpenCL…

bye
Marco