Problem with JCublas-0.2.3a_hotfix

I tried to use JCublas-0.2.3a_hotfix.
.dll files I’ve copied in directory of project and added jar. files to project, but during compilation I received
this error:
Error while loading native library with base name “JCublasEmu”
Operating system name: Windows XP
Architecture : x86
Architecture bit size: 32
Stack trace:
java.lang.UnsatisfiedLinkError: C:\Documents and Settings\1\workspace\Project1\JCublasEmu-windows-x86.dll: Can’t find dependent libraries
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at jcuda.LibUtils.loadLibrary(
at jcuda.jcublas.JCublas.assertInit(
at jcuda.jcublas.JCublas.cublasInit(
at Project1.main(

As you see I use it in emulation mode, but in non-emulation is still the same problem.
Can anybody help me?


Which version of CUDA are you using?

EDIT >> and did the “unfixed” version of CUBLAS work in general? << EDIT

As mentioned on the site, the library is compiled for the CUDA 3.0 beta. If you are using a different version of CUDA, the corresponding CUBLAS library may not be found (Note that some new functions have been introduced in CUBLAS with CUDA 3.0. These functions are already supported in this hotfix. But if you don’t need these or the few missing functions, and if still have CUDA 2.3 installed, you should stick to the current “unfixed” version of CUBLAS)


dumpbin /DEPENDENTS JCublas-windows-x86.dll

from the command line prints

  Image has the following dependencies:


so if the directory which contains the ‘cublas32_30_8.dll’ (usually C:\CUDA\bin) is contained in your PATH environment variable, it should find all required libraries.