Server Umzug


#21

ja das ist das Thema mit dem Peering, ich werde in den nächsten Tagen mal das verbesserte Peering bestellen

*** Edit ***

[QUOTE=Fancy;129826]Für mich persönlich ist es schnell genug, deshalb das bitte nicht als Beschwerde auffassen. Mich würde nur schon interessieren wo die Zeit liegenbleibt. Vergleiche ich z.B. (jeweils nur die Zeiten für die HTML Datei):

https://www.mikrocontroller.net/forum/mikrocontroller-elektronik

traceroute to www.mikrocontroller.net (188.40.52.210), 30 hops max, 60 byte packets
 1  router.home (10.0.0.1)  21.702 ms  21.828 ms  21.823 ms
 2  dslb-blub.pools.vodafone-ip.de (blub)  39.437 ms  49.071 ms  50.948 ms
 3  * * *
 4  188.111.171.216 (188.111.171.216)  51.773 ms 188.111.171.220 (188.111.171.220)  60.109 ms  61.107 ms
 5  92.79.212.193 (92.79.212.193)  62.505 ms 92.79.212.201 (92.79.212.201)  63.905 ms 92.79.212.193 (92.79.212.193)  69.872 ms
 6  92.79.213.170 (92.79.213.170)  70.809 ms 188.111.129.26 (188.111.129.26)  51.230 ms  52.180 ms
 7  amsix-gw.hetzner.de (80.249.209.55)  53.544 ms  40.671 ms decix2-gw.hetzner.de (80.81.193.164)  39.653 ms
 8  core22.hetzner.de (213.239.245.17)  41.165 ms  48.102 ms core1.hetzner.de (213.239.203.157)  40.802 ms
 9  juniper1.rz10.hetzner.de (213.239.245.42)  41.239 ms  41.196 ms juniper2.rz10.hetzner.de (213.239.245.46)  46.284 ms
10  juniper2.rz10.hetzner.de (213.239.245.46)  42.602 ms hos-tr1.ex3k3.rz10.hetzner.de (213.239.227.132)  40.320 ms hos-tr3.ex3k3.rz10.hetzner.de (213.239.227.196)  40.211 ms

mit: https://forum.byte-welt.net/java-forum/allgemeine-themen/

traceroute to forum.byte-welt.net (138.201.7.220), 30 hops max, 60 byte packets
 1  router.home (10.0.0.1)  21.779 ms  21.925 ms  21.918 ms
 2  dslb-blub.pools.vodafone-ip.de (blub)  39.521 ms  49.401 ms  51.366 ms
 3  * * *
 4  * 188.111.171.216 (188.111.171.216)  59.822 ms  60.843 ms
 5  92.79.212.201 (92.79.212.201)  62.205 ms 92.79.212.193 (92.79.212.193)  63.634 ms  69.994 ms
 6  188.111.129.26 (188.111.129.26)  72.408 ms  45.508 ms  51.354 ms
 7  decix2-gw.hetzner.de (80.81.193.164)  42.692 ms amsix-gw.hetzner.de (80.249.209.55)  39.835 ms decix2-gw.hetzner.de (80.81.193.164)  38.856 ms
 8  core24.hetzner.de (213.239.203.150)  40.116 ms core1.hetzner.de (213.239.203.157)  39.646 ms core24.hetzner.de (213.239.203.150)  39.612 ms
 9  core23.hetzner.de (213.239.203.154)  48.281 ms ex9k1.rz17.hetzner.de (213.239.203.234)  45.815 ms core23.hetzner.de (213.239.203.154)  41.869 ms
10  ex9k1.rz17.hetzner.de (213.239.203.230)  48.299 ms * *

Beide Seiten sind bei Hetzner und beide verwenden SSL.

Wenn die Verarbeitungszeit hier nur ~150ms dauert, was passiert dann in den >500ms (680 - 150) in denen der Browser einfach nur wartet? Und warum tritt das in dem anderen Forum so nicht auf?

Aber wie bereits geschrieben, reines Interesse, keine Beschwerde.

Gruß
Fancy[/QUOTE]

Ja ich finde die Zeiten aus den Logs die ich da auswerte auch etwas sehr gering, ich muss mal in der nächsten Zeit gucken dass ich noch mehr Quellen für Zahlen einbinde


#22

hmm - ich hab zum server folgende Laufzeiten

von meinem privat-Anschluss 213.211.248.7 Magdeburg

C:\Users\Administrator>tracert forum.byte-welt.net

Routenverfolgung zu forum.byte-welt.net [138.201.7.220] über maximal 30 Abschnitte:

1 <1 ms <1 ms <1 ms fritz.box [192.168.178.1]
2 12 ms 9 ms 8 ms 10.100.200.1
3 9 ms 8 ms 7 ms 172.16.65.189
4 10 ms 12 ms 9 ms 213.211.195.85
5 22 ms 25 ms 26 ms decix2-gw.hetzner.de [80.81.193.164]
6 27 ms 28 ms 25 ms core24.hetzner.de [213.239.203.150]
7 25 ms 28 ms 26 ms ex9k1.rz17.hetzner.de [213.239.203.234]
8 27 ms 32 ms 26 ms eagle-site.net [138.201.7.220]

Ablaufverfolgung beendet.

C:\Users\Administrator>

von meinem root 91.121.4.115 bei OVH RBX-1 in Roubaix, Frankreich bricht die Route komplett zusammen

root1:/home/cryptearth # traceroute forum.byte-welt.net
traceroute to forum.byte-welt.net (138.201.7.220), 30 hops max, 60 byte packets
 1  rbx1-3a-a9.fr.eu (91.121.4.252)  0.966 ms  3.441 ms  3.432 ms
 2  be11-149.rbx-g2-a9.fr.eu (37.187.231.67)  0.668 ms be11-314.rbx-g2-a9.fr.eu (37.187.231.103)  1.138 ms be11-314.rbx-g1-a9.fr.eu (37.187.231.101)  0.655 ms
 3  be100-1105.fra-1-a9.de.eu (37.187.232.88)  8.251 ms be100-1120.fra-5-a9.de.eu (37.187.232.96)  8.250 ms  8.230 ms
 4  decix-gw.hetzner.de (80.81.192.164)  8.463 ms  8.453 ms decix2-gw.hetzner.de (80.81.193.164)  8.424 ms
 5  core23.hetzner.de (213.239.203.154)  13.821 ms  14.018 ms core24.hetzner.de (213.239.203.150)  13.167 ms
 6  ex9k1.rz17.hetzner.de (213.239.203.230)  13.294 ms ex9k1.rz17.hetzner.de (213.239.203.234)  13.212 ms  13.194 ms
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
root1:/home/cryptearth #

Was mir gerade (gegen Mitternacht) aufgefallen ist - plötzlich extremer Performance-Verlust mit sehr hohen Ladezeiten. Dies geht dann teilweise sogar soweit das beim Schnell-Antworten das Script auslöst “Seite wirklich verlassen?” und mich dann mit dem Hinweis aufs Timeout von 30sec in den Editor schickt (das Problem hab ich ja schon mal versucht in nem anderen Thread zu verdeutlichen - weis nciht ob es mitlerweile wer verstanden hat was ich teils für Probleme habe).
Laufen da etwa mit cron immer zur Mitternacht entsprechend Scripte ? Falls ja: bitte mal den allgemeinen load über diese Zeit beobachten - da zumindest die Kombination WebServer - PHP und Datenbank sehr stark davon beeinträchtigt werden.

  • edit -

Zum Vergleich mal die beiden Routen zwischen mir und dem Root-Server:

C:\Users\Administrator>tracert root1.cryptearth.de

Routenverfolgung zu root1.cryptearth.de [91.121.4.115] über maximal 30 Abschnitte:

  1    <1 ms    <1 ms    <1 ms  fritz.box [192.168.178.1]
  2     9 ms    15 ms     7 ms  10.100.200.1
  3    12 ms     9 ms     9 ms  172.16.65.189
  4    13 ms    14 ms     8 ms  213.211.195.85
  5     *        *        *     Zeitüberschreitung der Anforderung.
  6    38 ms    31 ms    28 ms  be10-1105.rbx-g1-a9.fr.eu [37.187.232.89]
  7    37 ms    38 ms    32 ms  rbx1-3b-a9.fr.eu [37.187.231.94]
  8    30 ms    31 ms    30 ms  cryptearth.de [91.121.4.115]

Ablaufverfolgung beendet.

C:\Users\Administrator>
root1:/home/cryptearth # traceroute home.cryptearth.de
traceroute to home.cryptearth.de (213.211.248.7), 30 hops max, 60 byte packets
 1  rbx1-3a-a9.fr.eu (91.121.4.252)  6.896 ms  6.886 ms  6.877 ms
 2  be11-314.rbx-g2-a9.fr.eu (37.187.231.103)  0.622 ms be11-149.rbx-g1-a9.fr.eu (37.187.231.65)  0.915 ms be11-149.rbx-g2-a9.fr.eu (37.187.231.67)  0.883 ms
 3  be100-1120.fra-5-a9.de.eu (37.187.232.96)  8.354 ms be100-1105.fra-1-a9.de.eu (37.187.232.88)  8.825 ms  8.818 ms
 4  decix.hlkomm.net (80.81.192.91)  9.105 ms  9.099 ms  9.084 ms
 5  94.101.32.226 (94.101.32.226)  22.928 ms  22.920 ms  22.960 ms
 6  213.211.195.86 (213.211.195.86)  21.963 ms  22.079 ms  22.017 ms
 7  * * *
 8  port-ip-213-211-248-7.sta.reverse.mdcc-fun.de (213.211.248.7)  29.736 ms !X  33.694 ms !X  33.683 ms !X
root1:/home/cryptearth #

#23

An einigen performence Problemen bin ich gerade dran, das werde ich mir heute Nacht mal vornehme und einige Dinge durchstarten


#24

in den letzten Minuten gerade konstant auffällig, diverse Requests hintereinander jeweils mindestens abzählbare 5 sec ‘Warten auf forum.bytewelt.net’,
ist das intern irgendwie in Statistiken erfasst?

haben das andere im Moment auch, falls sie gerade hier lesen bzw. wenn bei anderen aktuell normal schnell, dann ja auch interessante Vergleich-Info,
kann jemand das ggfs. genauer routen-analysieren oder was immer für klare Aussagen hilft?

edit:
wie kann es dabei eigentlich immer ‘einige performence Problemen’ und ähnlich nebulöses geben?,
was machen denn Dummy-Pferdefan-Foren ohne alle Kenntnisse, zahlen die teureren Server mit Service für dort oft problemlosen Betrieb?
(hier der Monatspreis auch schon reichlich stolz…)

so groß ist das Forum hier doch auch nicht, kaum Betrieb, oder täuscht das, kann man da Kenngrößen nennen?
braucht es nicht mehr als: einen normal geeigneten Server-PC falls selber gehostet,
eine normal geeignete DB + Foren-Software (nach 20 Jahren sollte es doch was geben),
ohne allzu viele Schnörkel falls die so viele zusätzliche Probleme machen sollten,

installieren und läuft ohne weitere Arbeit, geht das nicht?

selber keine Kenntnisse für entsprechenden Betrieb, aber objekt gedachte Kritik sicher dennoch erlaubt :wink:


ich vermute ja immer noch das https als mögliche neue Ursache, kann man das nicht zumindest testweise wieder abschalten?
@EagleEye siehe auch internes Thema dazu,

ein Problem ja wie dort gesagt zusätzlich, dass Links innerhalb des Forums nicht mehr (zumindest meistens) SEO-schön umgewandelt werden, Beispiel:
https://forum.byte-welt.net/java-forum/awt-swing-javafx-swt/19140-jprogressbar-popup-text-beim-maushovern-new-post.html


#25

Etwas unscharf:
Seit etwa 10 Uhr (womöglich auch schon eher) harkt das Forum extremst.
Also SlaterB ist nicht der einzige Betroffene.


[QUOTE=SlaterB]edit:
[…]
wie kann es dabei eigentlich immer ‘einige performence Problemen’ und ähnlich nebulöses geben?,
was machen denn Dummy-Pferdefan-Foren ohne alle Kenntnisse, zahlen die teureren Server mit Service für dort oft problemlosen Betrieb?
(hier der Monatspreis auch schon reichlich stolz…)[/QUOTE]

Pferdefan: KramKram
Das (Test-)Forum von mir läuft immer, hat nie Probs, und ich bezahle dafür keinen Cent.
Aber auch mit einigen Nachteilen, kein https. usw…
Aber genug der Schleichwerbung.
Wenn unangemessen,
Link wieder entfernen.


#26

ja mir ist eine VM abgeraucht, die musste ich neustartet, seitdem braucht es etwas die zu aktualisieren, dann sollte alles wieder normal laufen.

Slater das hat alles nichts mit HTTPS zu tun :wink:


#27

Hm. Was heißt “etwas”? Ist immernoch extrem langsam…


#28

Ja das etwas ist etwas sehr lange geworden, die VMs werden mit der Zeit irgendwie langsam und beeinflussen sich was die Performence betrifft gegenseitig.
ich bin dran das zu beheben, ich hab einen Fehler bei der Configs der VMs gemacht
Das teste ich gerade mit einer VM, wenn das hilft werde ich es Stück für Stück auf die anderen ausweiten.


#29

Welche Virtualisierungslösung verwendest du denn?


#30

das ganze basiert auf KVM, ich hab aber einen kleinen Fehler bei der Festplatten Konfig der Gäste, statt VIRTIO hab ich IDE genommen was alles etwas langsamer macht


#31

Sehr langsam, also bei mir harkt und ruckelt alles, > 5 Sek. response time keine Übertreibung, “Benutzerfreundlichkeit von Kommunikationssystemen”, schon den ganzen Tag,
erst dachte ich, es wäre eine Art neuer Spam mechanismus oder Troller, aber das spinnt meine Phantasie wieder, naja morgen mal schauen.


#32

Leider kenne ich mich mit den Interna da ja nicht aus (Internet? Das ist dieses “e”-Symbol auf dem Desktop, gell?), aber … wenn man eine Forenseite aufmacht, und es >15 Sekunden (!) dauert, bis die Seite geladen wird, dann muss man doch rausfinden können, woran das liegt? (Ein ping an byte-welt.net braucht 6ms!)


#33

wow das ist ja heute immer noch so langsam
ich starte mal kurz das Forum neu vielleicht hilft das


#34

ich muss da wohl etwas tiefer steigen um die Ursache zu finden, das Wiki läuft flink aber das Forum hinkt rum


#35

Irgendwer versteckt sich hier…

~$ --2016-03-30 19:00:31--  https://forum.byte-welt.net/search.php?do=getnew
Auflösen des Hostnamen »forum.byte-welt.net (forum.byte-welt.net)«... 138.201.7.220
Verbindungsaufbau zu forum.byte-welt.net (forum.byte-welt.net)|138.201.7.220|:443... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 
  HTTP/1.1 200 OK
  Server: nginx/1.9.10
  Date: Wed, 30 Mar 2016 17:00:44 GMT
  Content-Type: text/html; charset=UTF-8
  Transfer-Encoding: chunked
  Connection: keep-alive
  Keep-Alive: timeout=20
  X-Powered-By: PHP/5.6.17-pl5-gentoo
  Set-Cookie: bb_lastvisit=1459357241; expires=Thu, 30-Mar-2017 17:00:41 GMT; Max-Age=31536000; path=/
  Set-Cookie: bb_lastactivity=0; expires=Thu, 30-Mar-2017 17:00:41 GMT; Max-Age=31536000; path=/
  Cache-Control: private
  Pragma: private                                                                                                                                                                                                                                  
Länge: nicht spezifiziert [text/html]                                                                                                                                                                                                              
In »»/dev/null«« speichern.                                                                                                                                                                                                                        
                                                                                                                                                                                                                                                   
/dev/null                                                        [ <=>                                                                                                                                            ]  36,58K  --.-KB/s   in 0,002s  
                                                                                                                                                                                                                                                   
2016-03-30 19:00:44 (19,4 MB/s) - »/dev/null« gespeichert [37460]                                                                                                                                                                                  
                                                                                                                                                                                                                                                   
                                                                                                                                                                                                                                                   
[1]+  Fertig                  wget -S -O /dev/null https://forum.byte-welt.net/search.php?do=getnew                                                                                                                                                
~$ traceroute forum.byte-welt.net
traceroute to forum.byte-welt.net (138.201.7.220), 64 hops max                                                                                                                                                                                     
  1   192.168.1.254  6,297ms  6,645ms  5,403ms                                                                                                                                                                                                     
  2   192.168.178.1  10,072ms  6,264ms  7,377ms                                                                                                                                                                                                    
  3   93.181.52.0  9,696ms  11,178ms  8,934ms                                                                                                                                                                                                      
  4   77.246.117.186  8,960ms  8,667ms  10,143ms                                                                                                                                                                                                   
  5   80.81.192.164  9,254ms  9,636ms  10,371ms                                                                                                                                                                                                    
  6   213.239.203.154  12,782ms  13,748ms  14,371ms                                                                                                                                                                                                
  7   213.239.203.230  15,343ms  21,558ms  12,795ms                                                                                                                                                                                                
  8   *  *  *                                                                                                                                                                                                                                      
  9   *  *  *                                                                                                                                                                                                                                      
 10   *  *  *                                                                                                                                                                                                                                      
 11   *  *  *                                                                                                                                                                                                                                      
 12   *  *  *                                                                                                                                                                                                                                      
 13   *  *  *                                                                                                                                                                                                                                      
 14   *  *  *                                                                                                                                                                                                                                      
 15   *  *  *                                                                                                                                                                                                                                      
 16   *  *  *                                                                                                                                                                                                                                      
 17   *  *  *                                                                                                                                                                                                                                      
 18   *  *  *                                                                                                                                                                                                                                      
 19   *  *  *                                                                                                                                                                                                                                      
 20   *  *  *                                                                                                                                                                                                                                      
 21   *  *  *                                                                                                                                                                                                                                      
 22   *  *  *                                                                                                                                                                                                                                      
 23   *  *  *                                                                                                                                                                                                                                      
 24   *  *  *                                                                                                                                                                                                                                      
 25   *  *  *                                                                                                                                                                                                                                      
 26   *  *  *                                                                                                                                                                                                                                      
 27   *  *  *                                                                                                                                                                                                                                      
 28   *  *  *                                                                                                                                                                                                                                      
 29   *  *  *                                                                                                                                                                                                                                      
 30   *  *

bye
TT


#36

Der Verbindungsaufbau und auch die Datenübertragung ist doch so schnell wie immer. Lediglich das PHP Gedöhns dauert ewig. Ruft man z.B. https://forum.byte-welt.net/images/misc/vbulletin4_logo.png auf, ist das Ergebnis sofort da.

Gruß
Fancy


#37

Such den Rechner such den Rechner, ja wo isser denn :smiley:

Das passt schon du bist da am Ende an meiner öffentlichen IP angekommen, danach gehts noch etwas weiter aber das siehst du nicht :wink:

*** Edit ***

Fancy, jo und was das alles noch schräger macht ist dass das wiki eigentlich zügig läuft
Ich bin gerade am gucken und es könnte sein dass die Festplatten einen weg haben, da werde ich heute Abend nachdem der Magen gefüllt ist weiter rein gucken.
Weil das könnte es erklären, sobald viel gelesen werden muss bricht die Performance zusammen.


#38

MySQL Slow Query Log eingeschalten? Gibt’s slow queries? Wenn ja wieso? Blöde Extension installiert die fette Joins macht? Tapatalk Update? Slow Queries die tmp tables bauen oder welche die nicht durch einen Index abgedeckt sind und somit einen Full-Table Scan machen und bei der Größe des Forums das schon mal dauert?

*** Edit ***

Die MySQL max connections zu niedrig und jetzt müssen aufgrund der Besucherzahlen immer Requests auf freie Connections warten?

Gibt’s statements die Table locks oder zu große row locks machen und daher müssen Requests warten bis der Lock freigegeben ist?


#39

Hast du ne IPgebundene Sperre eingebaut, nur sagen wir 15 Klicks auf das Forum, danach dauert alles <=15 Sekunden länger, zum Ruhen und Innehalten? :smiley:
Ne, nur Spaß, es läuft generell langsam, auch wenn man das Forum neu aufruft.
Wenn es apache nicht ist, kann es “nur” ~ bad script bzw. Datenbank sein.


#40

So heute Abend tauschen wir mal eine Festplatte, ich denke dass es dann besser wird. Wenn dem so ist wird später auch noch die 2. gewechselt