XXAMP Apache möchte nicht starten


#1

Hallo liebe Leute :),

ich habe das typische Problem das mein Apache-Server einfach nicht starten will, obwohl ich die Ports schon freigeräumt habe.

Als Warnung gibt er mir dies aus:

15:21:07 [Apache] Attempting to start Apache app…
15:21:08 [Apache] Status change detected: running
15:21:09 [Apache] Status change detected: stopped
15:21:09 [Apache] Error: Apache shutdown unexpectedly.
15:21:09 [Apache] This may be due to a blocked port, missing dependencies,
15:21:09 [Apache] improper privileges, a crash, or a shutdown by another method.
15:21:09 [Apache] Press the Logs button to view error logs and check
15:21:09 [Apache] the Windows Event Viewer for more clues
15:21:09 [Apache] If you need more help, copy and post this
15:21:09 [Apache] entire log window on the forums

Ich hab natürlich schon ürberall rummgeschaut, aber eine wirkliche Lösung habe ich leider nicht gefunden. :eek:
Könntet ihr mir bitte helfen?


#2

Das sind doch schon mal zwei ganz starke Tipps. Was steht denn dort?


#3

Genau, schaue mal in die Logdatei… Sind in dem log Verzeichnis des Installationpfades zu finden. Entweder blockt deine Firewall oder Virenscanner den Port oder ein anderer Servis hat bereits diesen Port in Benutzung. Skype zB. hat damals Probleme bereitet und den Apache beim hochfahren blockiert…


#4

Oder einfacher : don’t use XAMPP at all !
Stattdessen lieber aus den offiziellen Quellen aktuelle Pakete laden uns selbst aufsetzen.

[ot]was bei rauskommt wenn man xampp produktiv einsetzt, obwohl deutlich davon abgeraten wird, seh ich täglich auf arbeit : da crashed mal ne mysql-datenbank, hier bekommt man dann lustige fehler wie “verbindung verweigert (too many connections)” und so nebenbei scheint sich das ganze wohl komplett abzuschießen und der browser liefert nur ein timeout
na klar, wenn man es sich einfach macht und auf irgend so ner windows-kiste ne entwicklungsumgebung die für 5 bis max 10 leute gleichzeitig ausgelegt ist produktiv für über mehrere standorte verteilte über 1000 mitarbeiter einsetzen will … dass es da knallen muss sollte eigentlich klar sein
lieber gepflegt ne linux-maschine nehmen, produktiv-settings (gibt ja gute die sogar mit 10k+ umgehen können) nutzen, der hardware genug futter geben (also für ausreichend resourcen sorgen) und mal hier und da statt anfänger-php n ordentlich application-server nutzen … problem erledigt
und dafür bekommen unsere admins auch noch geld … ohne worte[/ot]


#5

Kann mich Sen nur anschließen…